wiki:SystemNotesOpenBSD54

Here are some preliminary instructions for OpenBSD 5.4.

These notes are quite dated. Keep in mind that many things have changed since they were created. In particular, Kea does not require python3 or SQLite. It can also use either OpenSSL or Botan, so Botan is no longer a strict dependency.

  • Install OpenBSD 5.4 and pick defaults.
  • The compiler collection (gcc and g++) is installed by default.
  • You'll need to install packages using the following command:
export PKG_PATH=http://ftp.openbsd.org/pub/OpenBSD/5.4/packages/`machine -a`/
pkg_add -v <pkg-name>

Here are the packages to install:

automake-1.13.1
bzip2
boost
git
gtest
libtool
python-3.3.2
log4cplus
botan

After these are installed, clone the Bind 10 git repository:

git clone git://git.bind10.isc.org/bind10 

Then, build Bind 10:

cd bind10
export AUTOCONF_VERSION=2.69
export AUTOMAKE_VERSION=1.13
autoreconf --install
./configure --prefix=/usr/local --with-gtest
make
make install
Last modified 3 years ago Last modified on Dec 3, 2014, 4:50:36 PM