Opened 7 years ago

Closed 6 years ago

#712 closed defect (worksforme)

wrong error message for xfrin if zone_name="."

Reported by: jreed Owned by: UnAssigned
Priority: low Milestone: Sprint-20110802
Component: xfrin Version:
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DNS Feature Depending on Ticket:
Estimated Difficulty: 2.0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

If the zone_name is a period, then xfrin configuration error for attempting a retransfer is:

{
    "error": "invalid RRClass: master=127.0.0.1"
}

Two problems:

  • zone_name="." should be okay
  • wrong message in this case

Subtickets

Change History (8)

comment:1 Changed 6 years ago by jinmei

  • Defect Severity set to N/A
  • Milestone set to Next-Sprint-Proposed
  • Sub-Project set to DNS

comment:2 Changed 6 years ago by stephen

  • Milestone changed from Next-Sprint-Proposed to Sprint-20110712

comment:3 Changed 6 years ago by stephen

  • Estimated Difficulty changed from 0.0 to 2

comment:4 Changed 6 years ago by vorner

  • Owner set to vorner
  • Status changed from new to accepted

comment:5 follow-up: Changed 6 years ago by vorner

  • Owner changed from vorner to jreed
  • Status changed from accepted to assigned

Hello

While investigating this issue, I discovered this:

> Xfrin retransfer {"zone_name": "."}
{
    "error": "bad zone class: \"zone_name\":\".\" (Unrecognized RR parameter string)"
}
> Xfrin retransfer "zone_name": "."
{
    "error": "Master address not given or configured for \\\"zone_name\\\":\\032\\\".\\\"."
}
> Xfrin retransfer zone_name=.
{
    "error": "Master address not given or configured for zone_name=."
}
> Xfrin retransfer zone_name .
{
    "error": "bad zone class: . (Unrecognized RR parameter string)"
}
> Xfrin retransfer .
"zone xfrin is started"

So, I have a guess: you typed zone_name="." master=127.0.0.1, which took zone_name="." as a whole as zone name and master=127.0.0.1 as the next positional parameter, the zone_class. In that sense, the error message from xfrin is correct, since it is clearly invalid class string.

But I agree this the response is not really intuitive. So, what do we do about it? I see some options:

  • Make bindctl understand understand keyword arguments
  • Have the help (eg. when typing Xfrin retransfer without parameters) better
  • Have some heuristic to say that the arguments look like meaning something else (eg. they contain =)

What do you propose?

comment:6 in reply to: ↑ 5 Changed 6 years ago by jreed

Replying to vorner:

So, I have a guess: you typed zone_name="." master=127.0.0.1, which took zone_name="." as a whole as zone name and master=127.0.0.1 as the next positional parameter, the zone_class. In that sense, the error message from xfrin is correct, since it is clearly invalid class string.

But that is correct syntax.

But I agree this the response is not really intuitive. So, what do we do about it? I see some options:

  • Make bindctl understand understand keyword arguments

I may misunderstand. This appears to already work.

  • Have the help (eg. when typing Xfrin retransfer without parameters) better
  • Have some heuristic to say that the arguments look like meaning something else (eg. they contain =)

What do you propose?

I can not reproduce the problem. I didn't clear document how I hit the problem and I can't remember.

I think this ticket may be closed. I can re-open if I realize how I did this.

comment:7 Changed 6 years ago by jreed

  • Owner changed from jreed to UnAssigned

comment:8 Changed 6 years ago by jreed

  • Resolution set to worksforme
  • Status changed from assigned to closed

I can't reproduce. Closing ticket. If it happens again, we can re-open it.

Note: See TracTickets for help on using tickets.