Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#3892 closed defect (duplicate)

Kea doesn't handle missing lease database configuration well

Reported by: tomek Owned by:
Priority: medium Milestone: Kea1.0-beta
Component: database-backend Version: git
Keywords: Cc:
CVSS Scoring: Parent Tickets:
Sensitive: no Defect Severity: N/A
Sub-Project: DHCP Feature Depending on Ticket:
Estimated Difficulty: 0 Add Hours to Ticket: 0
Total Hours: 0 Internal?: no

Description

When lease database is not specified, Kea starts, complains about missing database and tries to run, but then rapidly spews error messages about timers failing due to missing database.

This should be sanitized. Possible options:

  1. Allow running without database (that's preferred, especially for running in stateless-mode)
  1. Detect this error, print something out and terminate.
  1. Assume that if not specified memfile is the default, assume path and run normally.

Subtickets

Change History (3)

comment:1 Changed 2 years ago by hschempf

  • Milestone changed from Kea-proposed to Kea1.0

comment:2 Changed 2 years ago by tomek

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #3696.

comment:3 Changed 2 years ago by tomek

  • Milestone changed from Kea1.0 to Kea1.0-beta

Milestone renamed

Note: See TracTickets for help on using tickets.